while(n!=0)
        {
            num[i++]=n%2;
            n /= 2; //类似模拟除法的过程
        }
        for(j=i-1;j>=0;j--)
            printf("%d",num[j]);

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6113    Accepted Submission(s): 4738


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1 2 3
 

 

Sample Output
1 10 11
 
 
 
 
#include<stdio.h>
int main()
{
    int num[10500];
    int i,n,j;
    while( scanf("%d",&n) == 1 )
    {
        i = 0;
        while(n!=0)
        {
            num[i++]=n%2;
            n /= 2;
        }
        for(j=i-1;j>=0;j--)
            printf("%d",num[j]);
        printf("\n");
    }
      return 0;
}

posted on 2011-11-28 15:39  狸の舞  阅读(235)  评论(0编辑  收藏  举报