Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b's last digit number.

Sample Input

7 66 8 800

Sample Output

9 6

 

#include <stdio.h>
int main()
{
    int a,b;
    int num[8][4]={{6,2,4,8},{1,3,9,7},{6,4,6,4},{5,5,5,5},{6,6,6,6},{1,7,9,3},{6,8,4,2},{1,9,1,9}};
    while( scanf("%d%d",&a,&b)!=EOF )
    {
         int temp = a;
         if( temp==1 )
         {
                    printf("1\n");
         }
         else if(temp == 0)
         {
                    printf("0\n");
          }
          else
          {
                 if( temp == 5 )
                     printf( "5\n" );
                  else
                     printf("%d\n",num[temp-2][b%4]);         

          }
    }
    return 0;
}

posted on 2011-11-16 00:46  狸の舞  阅读(275)  评论(0编辑  收藏  举报