Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
Output
请输出按照要求改写后的英文句子。
Sample Input
i like acm i want to get an accepted
Sample Output
I Like Acm I Want To Get An Accepted
#include<stdio.h>
#include<string.h>
int main()
{
char str[1000], max;
int i, a, t;
while( gets( str ) )
{
t = strlen( str );
max = str[0];
for( i = 0; i < t; i++ )
{
if( max < str[i] )
{
max = str[i];
}
}
for( i = 0; i < t; i++ )
{
printf( "%c", str[i] );
if( str[i]==max )printf( "(max)" );
}
puts( "" );
}
return 0;
}