基于顺序存储结构的图书信息表的最佳位置图书的查找

描述

 

定义一个包含图书信息(书号、书名、价格)的顺序表,读入相应的图书数据来完成图书信息表的创建,然后根据指定的最佳位置的序号,查找该位置上的图书,输出相应图书的信息。

输入

总计n+m+2行。首先输入n+1行,其中,第一行是图书数目n,后n行是n本图书的信息(书号、书名、价格),每本图书信息占一行,书号、书名、价格用空格分隔,价格之后没有空格。其中书号和书名为字符串类型,价格为浮点数类型。然后输入m+1行,其中,第一行是一个整数m,代表查找m次,后m行每行内容为一个整数,代表待查找的图书的位置序号。

输出

输出m行 若查找成功: 输出内容为第i次查询的指定位置上的一本图书的信息(书号、书名、价格),书号、书名、价格用空格分隔,其中价格输出保留两位小数。 若查找失败: 只输出以下提示:抱歉,最佳位置上的图书不存在!

输入样例 1 

8
9787302257646 Data-Structure 35.00
9787302164340 Operating-System 50.00
9787302219972 Software-Engineer 32.00
9787302203513 Database-Principles 36.00
9787810827430 Discrete-Mathematics 36.00
9787302257800 Data-Structure 62.00
9787811234923 Compiler-Principles 62.00
9787822234110 The-C-Programming-Language 38.00
2
2
0

输出样例 1

9787302164340 Operating-System 50.00
Sorry,the book on the best position doesn't exist!
#include <iostream>
#include<iomanip>
using namespace std;
#define MAXSIZE 10000

typedef struct 
{
	string no;
	string name;
	double price;
}Book;

typedef struct
{
	Book *elem;
	int num;
}SqList;

void Input(SqList &L)
{
	int n;int i=0;
	cin>>n;
	string a,b;
	double c;
	while(i<n)
	{	
		cin>>a>>b>>c;
		if(i==n) break;
		L.elem[L.num].no=a;
		L.elem[L.num].name=b;
		L.elem[L.num].price=c;
		L.num++;
		i++;
	}
	return ;
}

void InitList(SqList &L)
{
	L.elem=new Book[MAXSIZE];
	if(!L.elem) return;
	L.num=0;
	return;
}

void BestLocate(SqList &L)
{
	int n;int i;int j;int no[10]; int k=0;
	cin>>n;
	for(i=0;i<n;i++)
	{
		cin>>no[i];
	}
	
	for(j=0;j<n;j++)
	{
		for(i=0;i<L.num-1;i++)
		{
			if(no[j]==i+1)
			{
				cout<<L.elem[i].no<<" "<<L.elem[i].name<<" "<<setiosflags(ios::fixed)<<setprecision(2)<<L.elem[i].price<<endl;
				k++;
			}
		}
		if(k==j)
		cout<<"Sorry,the book on the best position doesn't exist!"<<endl;
	}
}

int main()
{
	SqList L;
	InitList(L);
	Input(L); 
	BestLocate(L);
	return 0;
}

 

posted on 2020-02-15 02:09  海月CSDN  阅读(362)  评论(0编辑  收藏  举报