冠君
一直在努力

http://acm.nyist.net/JudgeOnline/problem.php?pid=5

 

Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
 
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 

利用string 中的find()函数
函数原型:size_type find( const char *str, size_type index );
返回str在字符串中第一次出现的位置(从index开始查找)。如果没找到则返回string::npos,

 

#include<iostream>
#include<string>
#include <cstring>
using namespace std;
int main()
{
 char a[11];
 string s;
 int i,count,k,n;
 int lena,lens;
 cin>>n;
 while(n--) {
  i=0;count=0;
  cin>>a>>s;
  lena=strlen(a),lens=s.length();
  while(i<lens-lena) {
   k=s.find(a,i);
   if(k!=string::npos) {
    count++;
    i=k+1;
   }
   else
    break;
  }
  cout<<count<<endl;
 }
 return 0;
}


posted on 2012-05-03 21:25  冠君———直在努力  阅读(206)  评论(0编辑  收藏  举报