See the picture below.

 

 

You are given ABAC and BCDE is parallel to BC. You are also given the area ratio between ADE and BDEC. You have to find the value of AD.

Input

Input starts with an integer T (≤ 25), denoting the number of test cases.

Each case begins with four real numbers denoting AB, AC, BC and the ratio of ADE and BDEC (ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.

Output

For each case of input you have to print the case number and AD. Errors less than 10-6 will be ignored.

Sample Input

4

100 100 100 2

10 12 14 1

7 8 9 10

8.134 9.098 7.123 5.10

Sample Output

Case 1: 81.6496580

Case 2: 7.07106781

Case 3: 6.6742381247

Case 4: 7.437454786

 

 

题意:已知AB, AC, BC, ADE与DEBC面积比值,求AD.

分析:ADE与ABC面积之比等于AD与AB之比

 

 

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<math.h>
using namespace std;
typedef long long LL;
#define maxn  55000
#define INF 1e+7

int main()
{
    int T, t=1;
    double ab, ac, bc, r,ad;

    scanf("%d", &T);

    while(T --)
    {
        scanf("%lf %lf %lf %lf", &ab, &ac, &bc, &r);

         r = r /(r+1);
         r = sqrt(r);
         ad = ab * r;
        printf("Case %d: ",t++);
        printf("%.10f\n",ad);

    }
    return 0;
}
View Code

 

 

 

 

 

posted on 2016-08-10 09:52  不忧尘世不忧心  阅读(169)  评论(0编辑  收藏  举报