http://acm.hust.edu.cn/vjudge/contest/121397#problem/A

 

 

Description

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

 

 

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

 

数学渣渣,表示真的不会~

 

 

 

 

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<ctype.h>
#include<stdlib.h>
#include <iostream>
#include<algorithm>
#include<queue>
#define oo 0x3f3f3f3f
using namespace std;
const int maxn = 1000010;
const double P = 0.57721566490153286060651209;
double a[maxn];
int main()
{

    for(int i = 1; i <= 1000000; i++)
        a[i] = a[i-1] + 1.0/i;

    int cnt = 1;
    int T;

    scanf("%d", &T);

    while(T--)
    {
        int n;
        scanf("%d", &n);

        double ans;

        if(n <= 1000000)
            ans = a[n];
        else
            ans = log(n+0.5) + P;

        printf("Case %d: %.10lf\n", cnt++, ans);
    }

    return 0;
}
View Code

 

posted on 2016-08-04 20:23  不忧尘世不忧心  阅读(205)  评论(0编辑  收藏  举报