题目链接

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

分析:
求一个数的所有的小于该数且与该数互质的数的个数,也就是欧拉函数的应用。

直接套欧拉函数公式,即将n素分解后有n=p1k1*p2k2…pm^km,则euler(n)=n(1-1/p1)(1-1/p2)…(1-1/pm) 。

代码:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
ll get_euler(ll n)//欧拉函数的应用
{
    ll ans=n;
    for(ll i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            ans=ans/i*(i-1);
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        ans=ans/n*(n-1);
    return ans;
}
int main()
{
    ll n;
    while(scanf("%lld",&n),n)
        printf("%lld\n",get_euler(n));
    return 0;
}
posted on 2018-04-11 10:13  渡……  阅读(309)  评论(0编辑  收藏  举报