题目链接

Problem Description
Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input
The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output
For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input
6
1.0 1.0
2.0 1.0
4.0 1.0
8.0 1.0
16.0 1.0
7.00 3.00

Sample Output
0.000000
1.693147
2.386294
3.079442
3.772589
1.847298

分析:
对于一根长度为 L 的蛋糕,每次等概率的取一个点将其分成两半,然后吃掉左边一半,直到剩下的长度小于 d,计算需要吃(分割)次数的数学期望。

显然,如果 L/d 相同,则结果必定相同
根据 ln2 = 0.693147 可以推测出结果应该是 ln(L/d) + 1
再单独考虑不需要分割的情况( d>=L )

定义 f(x) 为长度为 x 时,的数学期望

对于 f(x) 若 x<=d 这时已经满足条件,有 f(x)=0

而对于 x>d 其结果应该是从上面任选一点后求其右半部分的数学期望再加上本次分割的 1

用φ表示从长度为x的线段上取到一个点的概率,则
即φ=1/x

其中需要注意的就是:

因此可以得知 f(x) 不是一个连续函数
但是我们迭代运算的部分都是 x > d 部分

综上所述:

代码:

#include<stdio.h>
#include<istream>
#include<cmath>
using namespace std;
double d,l;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf",&l,&d);
        if(l<=d)
            printf("0.000000\n");
        else
            printf("%.6lf\n",1+log(l/d));
    }
    return 0;
}
posted on 2017-10-28 19:08  渡……  阅读(1442)  评论(1编辑  收藏  举报