随笔 - 346,  文章 - 0,  评论 - 39,  阅读 - 26万

题目链接

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

分析:

完全背包+最小值+恰好装满。

1.完全背包,与01背包在一维转移方程的区别是,01背包一维j的循环是逆序的,而完全背包是正序的,原因是完全背包可以取任意件,具体原因可参照背包九讲。

2.最小值,a>b?a:b换成a<b?a:b即可。

3.恰好装满,若是求最大值,dp数组元素初始化为-∞;若是求最小值,初始化为+∞,最后若dp[V]的值改变,则输出dp[V],反之则输出不满足条件。若不需要恰好装满,则初始化为0。

代码:

#include<iostream>
#include<stdio.h>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int kong,man,i,j,sum=0;
        scanf("%d%d",&kong,&man);
        int p[10004],w[10004],dp[10004];
        int m;
        scanf("%d",&m);
        for(i=1; i<=m; i++)
            scanf("%d%d",&p[i],&w[i]);
        for(i=1; i<10004; i++)
            dp[i]=0x3f3f3f;
        dp[0]=0;
        for(i=1; i<=m; ++i)
            for(j=w[i]; j<=man-kong; ++j)
            {
                dp[j]=min(dp[j],dp[j-w[i]]+p[i]);
            }
        if(dp[man-kong]!=0x3f3f3f)
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[man-kong]);
        else
            printf("This is impossible.\n");
    }
    return 0;
}
posted on   渡……  阅读(180)  评论(0编辑  收藏  举报
编辑推荐:
· 现代计算机视觉入门之:什么是图片特征编码
· .NET 9 new features-C#13新的锁类型和语义
· Linux系统下SQL Server数据库镜像配置全流程详解
· 现代计算机视觉入门之:什么是视频
· 你所不知道的 C/C++ 宏知识
阅读排行:
· 不到万不得已,千万不要去外包
· C# WebAPI 插件热插拔(持续更新中)
· 会议真的有必要吗?我们产品开发9年了,但从来没开过会
· 【译】我们最喜欢的2024年的 Visual Studio 新功能
· 如何打造一个高并发系统?

< 2025年1月 >
29 30 31 1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31 1
2 3 4 5 6 7 8
点击右上角即可分享
微信分享提示