小墨在努力!!
吗了个b的。。。。。

Simply Syntax

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 181    Accepted Submission(s): 97

Problem Description
In the land of Hedonia the official language is Hedonian. A Hedonian professor had noticed that many of her students still did not master the syntax of Hedonian well. Tired of correcting the many syntactical mistakes, she decided to challenge the students and asked them to write a program that could check the syntactical correctness of any sentence they wrote. Similar to the nature of Hedonians, the syntax of Hedonian is also pleasantly simple. Here are the rules:
0. The only characters in the language are the characters p through z and N, C, D, E, and I.
1. Every character from p through z is a correct sentence.
2. If s is a correct sentence, then so is Ns.
3. If s and t are correct sentences, then so are Cst, Dst, Est and Ist.
4. Rules 0. to 3. are the only rules to determine the syntactical correctness of a sentence.
You are asked to write a program that checks if sentences satisfy the syntax rules given in Rule 0. - Rule 4.
 
Input
The input consists of a number of sentences consisting only of characters p through z and N, C, D, E, and I. Each sentence is ended by a new-line character. The collection of sentences is terminated by the end-of-file character. If necessary, you may assume that each sentence has at most 256 characters and at least 1 character.
 
Output
The output consists of the answers YES for each well-formed sentence and NO for each not-well-formed sentence. The answers are given in the same order as the sentences. Each answer is followed by a new-line character, and the list of answers is followed by an end-of-file character.
 
Sample Input
Cp Isz NIsz Cqpq
 
Sample Output
NO YES YES NO
 
 
#include <stdio.h>
#include <string.h>
int main ()
{    
      char arr[256];    
      while (scanf ("%s",arr) != EOF)    
      {          
            getchar();          
            int len = strlen (arr) ,count = 0 ,flog = 0;          
            for (int i = len - 1 ;i >= 0 ;i--)          
            {               
                  if (arr[i] >= 'p' && arr[i] <= 'z') count++;               
                  else if (arr[i] == 'C' || arr[i] == 'D' ||arr[i] == 'E' ||arr[i] =='I') count--;               
                  else if (arr[i] == 'N'){}               
                  else flog = 1;          
            }          
            if (!flog && count)printf("YES\n");          
            else printf("NO\n");    
      }    
      return 0;
}
 
//从后面网前面遍历,还有就是那个递归,不过递归比这个直接写慢很多。。。。
posted on 2011-11-02 12:32  小墨在努力!!  阅读(251)  评论(0编辑  收藏  举报