小墨在努力!!
吗了个b的。。。。。

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 998 Accepted Submission(s): 533


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output
For each case, output a integer standing for the frog's ability at least they should have.

Sample Input
6 1 2 2 25 3 3 11 2 18

Sample Output
4 11
 
#include <stdio.h>
#include <algorithm>
using namespace
std;
int
n,a[500002],m;
int
solve(int t)
{

    int
count=0,total=0;
    for
(int i=1;i<=n+1;i++)
    {

           total+=a[i];   
           if
(total>t)
           {
count++;i--;total=0;}
           if
(total==t||(i==n+1&&total<t))
           {
count++;total=0;}          
           if
(count>m)
           return
0;    
    }

    return
1;
}

int
main()
{

    int
l,k,p,temp;
    while
(scanf("%d %d %d",&l,&n,&m)!=EOF)
    {

        int
sum=0;
        for
(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
        a[n+1]=l,a[0]=0;
        sort(a,a+n+2);
        for
(int i=n+1;i>=1;i--)
         a[i]=a[i]-a[i-1];
        int
min=l/m,max=l;
        while
(max>min)
        {

           k=(min+max)/2;
           if
(solve(k))
              max=k;
           else

              min=k+1;
        }

        printf("%d\n",max);
    }

    return
0;
}
刚开始ACM之路,做的不是很好,希望大家多提出建议!!!

 
posted on 2011-09-22 21:12  小墨在努力!!  阅读(272)  评论(0编辑  收藏  举报