pat 1074 Reversing Linked List (25分) 链表反转

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤) which is the total number of nodes, and a positive K (≤) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
 

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

1
2
3
4
5
6
7
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

1
2
3
4
5
6
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

解题思路:

这道题目,用一个vector,按照顺序把 节点依次存起来,输入是4 - > 1 - > 6 -> 3 ->5 -> 2  按照 1->2->3->4->5->6存放,再反转vector

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<vector>
#include<algorithm>
 
using namespace std;
 
typedef struct Node{
    int data;
    int order;
    int next;
}Node;
Node nodes[100010];
int main(){
//  freopen("C:\\Users\\zzloyxt\\Desktop\\1.txt","r",stdin);
     
    int first,n,k;
    scanf("%d %d %d",&first,&n,&k);
     
    for(int i=0;i<n;i++){
        int data,order,next;
        scanf("%d %d %d",&data,&order,&next);
        nodes[data].data = data;
        nodes[data].order = order;
        nodes[data].next = next;       
    }
    vector<Node> V;
     
    for(int i=first;i!=-1;i = nodes[i].next){
        V.push_back(nodes[i]);
    }
     
    for(int i=0;i<=V.size()-k;i=i+k){
        reverse(V.begin()+i,V.begin()+i+k);
    }
     
    for(int i=0;i<V.size()-1;i++){
        printf("%05d %d %05d\n",V[i].data,V[i].order,V[i+1].data);
    }
     
    printf("%05d %d %d\n",V[V.size()-1].data, V[V.size()-1].order,-1);
     
    return 0;
}

 

注意这里的reverse()函数,传的是iterator,reverse(V.begin(), V.begin() + k),最后一个单独输出

 

posted @   my日常work  阅读(207)  评论(0编辑  收藏  举报
编辑推荐:
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· Manus的开源复刻OpenManus初探
· 写一个简单的SQL生成工具
· AI 智能体引爆开源社区「GitHub 热点速览」
· C#/.NET/.NET Core技术前沿周刊 | 第 29 期(2025年3.1-3.9)
点击右上角即可分享
微信分享提示