3124. BSGS

题目链接

3124. BSGS

给定正整数 \(a,p,b\),数据保证 \(a\)\(p\) 互质。

求满足 \(a^x≡b \pmod p\) 的最小非负整数 \(x\)

输入格式

每个测试文件中最多包含 \(100\) 组测试数据。

每组数据中,每行包含 \(3\) 个正整数 \(a,p,b\)

\(a=p=b=0\) 时,表示测试数据读入完全。

输出格式

对于每组数据,输出一行。

如果有 \(x\) 满足该要求,输出最小的非负整数 \(x\),否则输出 No Solution

数据范围

\(1 \le a,p,b \le 2^{31}-1\)

输入样例:

3 5 2
3 2 1
0 0 0

输出样例:

3
0

解题思路

bsgs

有欧拉定理:\(a^{\alpha(p)}\equiv 1(\bmod p)\),则有 \(a^x\equiv a^{x\bmod \alpha(p)}(\bmod p)\),则答案范围为 \([0,\alpha(p)-1]\),为了简便计算通常会扩大查询的范围,计算 \(a^{t}\equiv b(\bmod p)\)\(t\) 的最小非负整数解 \(t\),设 \(t=k\times x-y\),其中 \(x\in [1,k],y\in [0,k-1],k=\sqrt{p}+1\),则有 \(a^{k\times x}\equiv b\times a^y(\bmod p)\),将所有的 \(b\times a^y\) 的取值放入哈希表,同时存储最大的 \(y\),然后遍历 \(x\) 即可

  • 时间复杂度:\(O(\sqrt{p})\)

代码

// Problem: BSGS
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/3127/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
// 
// Powered by CP Editor (https://cpeditor.org)

// %%%Skyqwq
#include <bits/stdc++.h>
 
//#define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
 
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
 
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
 
template <typename T> void inline read(T &x) {
    int f = 1; x = 0; char s = getchar();
    while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
    while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
    x *= f;
}

int a,p,b;
int bsgs(int a,int b,int p)
{
	b=b%p;
	if(1%p==b)return 0;
	int k=sqrt(p)+1;
	unordered_map<int,int> hash;
	for(int i=0,j=b;i<k;i++)
	{
		hash[j]=i;
		j=(LL)j*a%p;
	}
	int ak=1;
	for(int i=1;i<=k;i++)ak=(LL)ak*a%p;
	for(int i=1,j=ak;i<=k;i++)
	{
		if(hash.count(j))return i*k-hash[j];
		j=(LL)j*ak%p;
	}
	return -1;		
}
int main()
{
	while(cin>>a>>p>>b,a||b||p)
	{
		int res=bsgs(a,b,p);
		if(res>=0)cout<<res<<'\n';
		else
			puts("No Solution");
	}    
    return 0;
}
posted @ 2022-10-14 21:21  zyy2001  阅读(19)  评论(0编辑  收藏  举报