367. 学校网络
题目链接
367. 学校网络
一些学校连接在一个计算机网络上,学校之间存在软件支援协议,每个学校都有它应支援的学校名单(学校 \(A\) 支援学校 \(B\),并不表示学校 \(B\) 一定要支援学校 \(A\))。
当某校获得一个新软件时,无论是直接获得还是通过网络获得,该校都应立即将这个软件通过网络传送给它应支援的学校。
因此,一个新软件若想让所有学校都能使用,只需将其提供给一些学校即可。
现在请问最少需要将一个新软件直接提供给多少个学校,才能使软件能够通过网络被传送到所有学校?
最少需要添加几条新的支援关系,使得将一个新软件提供给任何一个学校,其他所有学校就都可以通过网络获得该软件?
输入格式
第 \(1\) 行包含整数 \(N\),表示学校数量。
第 \(2..N+1\) 行,每行包含一个或多个整数,第 \(i+1\) 行表示学校 \(i\) 应该支援的学校名单,每行最后都有一个 \(0\) 表示名单结束(只有一个 \(0\) 即表示该学校没有需要支援的学校)。
输出格式
输出两个问题的结果,每个结果占一行。
数据范围
\(2 \\le N \\le 100\)
输入样例:
5
2 4 3 0
4 5 0
0
0
1 0
输出样例:
1
2
解题思路
缩点
缩点后,显然第一问答案为起点数量
考虑第二问,即最少需要添加多少边使整张图变为强连通分量,设缩点后的起点和终点数量分别为 \(p,q\),任意地,有 \(p\leq q\),否则可以将整张图反向考虑,结果还是一样的。\(p=1\) 时,显然需要添加 \(q\) 条边使终点连向起点,\(p>1\) 时,\(q>1\),则一定可以找到两个不同的起点 \(p_1,p_2\),两个不同的终点 \(q_1,q_2\),使 \(p_1\) 能到 \(q_1\),\(p_2\) 能到 \(q_2\),则最好在 \(q_1\) 和 \(p_2\) 之间连一条边,这样起点和终点剩下 \(p-1\) 和 \(q-1\) 个点,直到 \(p=1\),此时连了 \(p-1\) 条边,终点还剩 \(q-(p-1)\) 条边,再连 \(q-(p-1)\) 条边即可,总的需要连边数量为 \(q\),\(p\geq q\),同理需要连边数量为 \(p\),故答案为 \(max(p,q)\),另外缩点后如果只有一个点的情况,起点和终点数量都为 \(1\),而显然不需要连边,这个需要特判
- 时间复杂度:\(O(n+m)\)
代码
// Problem: 学校网络
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/369/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
//
// Powered by CP Editor (https://cpeditor.org)
// %%%Skyqwq
#include <bits/stdc++.h>
//#define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
template <typename T> void inline read(T &x) {
int f = 1; x = 0; char s = getchar();
while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
x *= f;
}
const int N=105;
int n;
int dfn[N],low[N],timestamp,scc_cnt,id[N],stk[N],top;
int din[N],dout[N];
bool in_stk[N];
vector<int> adj[N];
void tarjan(int x)
{
dfn[x]=low[x]=++timestamp;
stk[++top]=x,in_stk[x]=true;
for(int y:adj[x])
{
if(!dfn[y])
{
tarjan(y);
low[x]=min(low[x],low[y]);
}
else if(in_stk[y])low[x]=min(low[x],dfn[y]);
}
if(low[x]==dfn[x])
{
int y;
scc_cnt++;
do
{
y=stk[top--];
in_stk[y]=false;
id[y]=scc_cnt;
}while(y!=x);
}
}
int main()
{
cin>>n;
for(int i=1;i<=n;i++)
{
int x;
while(cin>>x,x)adj[i].pb(x);
}
for(int i=1;i<=n;i++)
if(!dfn[i])tarjan(i);
for(int i=1;i<=n;i++)
for(int j:adj[i])
if(id[i]!=id[j])din[id[j]]++,dout[id[i]]++;
int res1=0,res2=0;
for(int i=1;i<=scc_cnt;i++)
{
if(!din[i])res1++;
if(!dout[i])res2++;
}
cout<<res1<<'\n'<<(scc_cnt==1?0:max(res1,res2));
return 0;
}