827. 双链表
题目链接
827. 双链表
实现一个双链表,双链表初始为空,支持 \(5\) 种操作:
在最左侧插入一个数;
在最右侧插入一个数;
将第 \(k\) 个插入的数删除;
在第 \(k\) 个插入的数左侧插入一个数;
在第 \(k\) 个插入的数右侧插入一个数
现在要对该链表进行 \(M\) 次操作,进行完所有操作后,从左到右输出整个链表。
注意:题目中第 \(k\) 个插入的数并不是指当前链表的第 \(k\) 个数。例如操作过程中一共插入了 \(n\) 个数,则按照插入的时间顺序,这 \(n\) 个数依次为:第 \(1\) 个插入的数,第 \(2\) 个插入的数,…第 \(n\) 个插入的数。
输入格式
第一行包含整数 \(M\),表示操作次数。
接下来 \(M\) 行,每行包含一个操作命令,操作命令可能为以下几种:
L x
,表示在链表的最左端插入数 \(x\)。R x
,表示在链表的最右端插入数 \(x\)。D k
,表示将第 \(k\) 个插入的数删除。IL k x
,表示在第 \(k\) 个插入的数左侧插入一个数。IR k x
,表示在第 \(k\) 个插入的数右侧插入一个数。
输出格式
共一行,将整个链表从左到右输出。
数据范围
\(1≤M≤100000\)
所有操作保证合法。
输入样例:
10
R 7
D 1
L 3
IL 2 10
D 3
IL 2 7
L 8
R 9
IL 4 7
IR 2 2
输出样例:
8 7 7 3 2 9
解题思路
双链表
对于每个节点都有左指针与右指针,分别指向左节点与右节点,本题将 \(0\) 和 \(1\) 分别作为头节点和尾节点,然后模拟一遍插入与删除操作即可
- 时间复杂度:\(O(1)\)
代码
// Problem: 双链表
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/829/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
//
// Powered by CP Editor (https://cpeditor.org)
// %%%Skyqwq
#include <bits/stdc++.h>
//#define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
template <typename T> void inline read(T &x) {
int f = 1; x = 0; char s = getchar();
while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
x *= f;
}
const int N=1e5+5;
int m,e[N],ne[N],l[N],r[N],idx;
void init()
{
r[0]=1;
l[1]=0;
idx=2;
}
void add(int k,int x)
{
e[idx]=x;
l[idx]=k;
r[idx]=r[k];
l[r[k]]=idx;
r[k]=idx++;
}
void remove(int k)
{
l[r[k]]=l[k];
r[l[k]]=r[k];
}
int main()
{
init();
cin>>m;
while(m--)
{
string op;
int k,x;
cin>>op;
if(op=="L")
{
cin>>x;
add(0,x);
}
else if(op=="R")
{
cin>>x;
add(l[1],x);
}
else if(op=="D")
{
cin>>k;
remove(k+1);
}
else if(op=="IL")
{
cin>>k>>x;
add(l[k+1],x);
}
else
{
cin>>k>>x;
add(k+1,x);
}
}
for(int i=r[0];i!=1;i=r[i])cout<<e[i]<<' ';
return 0;
}