#855. 异或和
题目链接
#855. 异或和
给定一个长度为 \(n\) 的数组 \(a_1, a_2, ..., a_n\)。
请你求出下面式子的模\(1e9+7\)的值。
\[\sum_{i=1}^{n-1} \sum_{j=i+1}^{n} (a_i \; XOR \; a_j)
\]
输入格式
第一行一个数字 \(n\)。
接下来一行 \(n\) 个整数 \(a_1, a_2, \dots, a_n\)。
输出格式
一行一个整数表示答案。
样例输入
3
1 2 3
样例输出
6
数据规模
所有数据保证 \(2 \leq n \leq 300000, 0 \leq a_i < 2^{60}\)。
解题思路
思维
计算任意两个数的异或和,将每一位为 \(1\) 的数的个数记录下来,然后按位计算该位的贡献
- 时间复杂度:\(O(60n)\)
代码
// %%%Skyqwq
#include <bits/stdc++.h>
// #define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
template <typename T> void inline read(T &x) {
int f = 1; x = 0; char s = getchar();
while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
x *= f;
}
const int N=3e5+5,mod=1e9+7;
int n,a[60],res;
int main()
{
help;
cin>>n;
for(int i=1;i<=n;i++)
{
LL x;
cin>>x;
for(int j=0;j<60;j++)
a[j]+=(x>>j&1);
}
for(int i=0;i<60;i++)
res=(1ll*res+1ll*(1ll<<i)%mod*a[i]%mod*(n-a[i])%mod)%mod;
cout<<res;
return 0;
}