3155. 冰雹数

题目链接

3155. 冰雹数

任意给定一个正整数 \(N\)

如果是偶数,执行: \(N/2\)
如果是奇数,执行: \(N×3+1\)
生成的新的数字再执行同样的动作,循环往复。

通过观察发现,这个数字会一会儿上升到很高,一会儿又降落下来。

就这样起起落落的,但最终必会落到 “1”。

这有点像小冰雹粒子在冰雹云中翻滚增长的样子。

比如 \(N=9\) 时:

9,28,14,7,22,11,34,17,52,26,13,40,20,10,5,16,8,4,2,1

可以看到,\(N=9\) 的时候,这个“小冰雹”最高冲到了 \(52\) 这个高度。

给定数字 \(N\),请你求出不大于 \(N\) 的数字,经过冰雹数变换过程中,最高冲到了多少。

输入格式

一个正整数 \(N\)

输出格式

一个正整数,表示不大于 \(N\) 的数字,经过冰雹数变换过程中,最高冲到了多少。

数据范围

\(0<N<10^6\)

输入样例1:

10

输出样例1:

52

输入样例2:

100

输出样例2:

9232

解题思路

模拟

注意,这里不用记忆化搜索,由于存的数据过多,反而会加大查询的时间,从而超时,由于实际上一个数最终到 \(1\) 迭代的次数不会很多,可以直接模拟

  • 时间复杂度:\(O(n)\)

代码

// Problem: 冰雹数
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/description/3158/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
// 
// Powered by CP Editor (https://cpeditor.org)

// %%%Skyqwq
#include <bits/stdc++.h>
 
//#define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
 
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
 
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
 
template <typename T> void inline read(T &x) {
    int f = 1; x = 0; char s = getchar();
    while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
    while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
    x *= f;
}

int n;
LL res;
LL dfs(LL x)
{
	LL res=x;
	while(x!=1)
	{
		if(x&1)x=x*3+1;
		else
			x>>=1;
		res=max(res,x);
	}
	return res;
}
int main()
{
	cin>>n;
    for(int i=1;i<=n;i++)res=max(res,1ll*dfs(i));
    cout<<res;
    return 0;
}
posted @ 2022-03-31 19:07  zyy2001  阅读(140)  评论(0编辑  收藏  举报