840. 模拟散列表

题目链接

840. 模拟散列表

维护一个集合,支持如下几种操作:

  1. I x,插入一个数 \(x\)

  2. Q x,询问数 \(x\) 是否在集合中出现过;

现在要进行 \(N\) 次操作,对于每个询问操作输出对应的结果。

输入格式

第一行包含整数 $N%,表示操作数量。

接下来 \(N\) 行,每行包含一个操作指令,操作指令为 I xQ x 中的一种。

输出格式

对于每个询问指令 Q x,输出一个询问结果,如果 \(x\) 在集合中出现过,则输出 Yes,否则输出 No

每个结果占一行。

数据范围

\(1≤N≤10^5\)
\(−10^9≤x≤10^9\)

输入样例:

5
I 1
I 2
I 3
Q 2
Q 5

输出样例:

Yes
No

每次操作:

  • 时间复杂度:\(O(1)\)

代码

  • 拉链法
// Problem: 模拟散列表
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/842/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
// 
// Powered by CP Editor (https://cpeditor.org)

// %%%Skyqwq
#include <bits/stdc++.h>
 
//#define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
 
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
 
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
 
template <typename T> void inline read(T &x) {
    int f = 1; x = 0; char s = getchar();
    while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
    while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
    x *= f;
}

const int N=1e5+3;
int n,h[N],ne[N],e[N],idx;
void insert(int x)
{
	int k=(x%N+N)%N;
	e[idx]=x;
	ne[idx]=h[k];
	h[k]=idx++;
}
bool find(int x)
{
	int k=(x%N+N)%N;
	for(int i=h[k];~i;i=ne[i])
		if(e[i]==x)return true;
	return false;
}
int main()
{
	memset(h,-1,sizeof h);
    cin>>n;
    while(n--)
    {
    	int x;
    	char op[2];
    	cin>>op>>x;
    	if(*op=='I')insert(x);
    	else
    		puts(find(x)?"Yes":"No");
    }
    return 0;
}
  • 开放寻址法
// Problem: 模拟散列表
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/842/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
// 
// Powered by CP Editor (https://cpeditor.org)

// %%%Skyqwq
#include <bits/stdc++.h>
 
//#define int long long
#define help {cin.tie(NULL); cout.tie(NULL);}
#define pb push_back
#define fi first
#define se second
#define mkp make_pair
using namespace std;
 
typedef long long LL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
 
template <typename T> bool chkMax(T &x, T y) { return (y > x) ? x = y, 1 : 0; }
template <typename T> bool chkMin(T &x, T y) { return (y < x) ? x = y, 1 : 0; }
 
template <typename T> void inline read(T &x) {
    int f = 1; x = 0; char s = getchar();
    while (s < '0' || s > '9') { if (s == '-') f = -1; s = getchar(); }
    while (s <= '9' && s >= '0') x = x * 10 + (s ^ 48), s = getchar();
    x *= f;
}

const int N=2e5+3,null=0x3f3f3f3f;
int h[N];
int find(int x)
{
	int k=(x%N+N)%N;
	while(h[k]!=null&&h[k]!=x)
	{
		k++;
		if(k==N)k=0;
	}
	return k;
}
int main()
{
	int n;
	memset(h,0x3f,sizeof h);
	for(cin>>n;n;n--)
	{
		int x;
		char op[2];
		cin>>op>>x;
		int k=find(x);
		if(*op=='I')h[k]=x;
		else
			puts(h[k]==x?"Yes":"No");
	}    
    return 0;
}
posted @ 2022-02-19 17:47  zyy2001  阅读(24)  评论(0编辑  收藏  举报