hdu1556:Color the ball(差分)

http://acm.hdu.edu.cn/showproblem.php?pid=1556

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

 

 

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

 

 

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

 

 

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

 

Sample Output

1 1 1
3 2 1

解题思路:

差分裸题

#include <stdio.h>
#include <string.h>
#define N 100200
int s[N];
int main()
{
	int n, i, a, b;
	while(scanf("%d", &n), n!=0)
	{
		memset(s, 0, sizeof(s));
		for(i=1; i<=n; i++)
		{
			scanf("%d%d", &a, &b);
			s[a]++;
			s[b+1]--;
		}
		for(i=1; i<n; i++)
		{
			s[i]+=s[i-1];
			printf("%d ", s[i]);
		}
		printf("%d\n", s[n]+s[n-1]);
	}
	return 0;
}

 

posted @ 2019-07-02 12:02  宿星  阅读(99)  评论(0编辑  收藏  举报