hdu3829:Cat VS Dog (最大独立集)

https://vjudge.net/problem/HDU-3829

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3

题意分析:

动物园里有n只猫和m条狗,每个小孩有喜欢和不喜欢动物编号,现在管理员要把动物移走,如果一个小孩喜欢的动物没被移走,且不喜欢的动物被移走了,那他就会开心,问管理员最多可以让多少下回开心。

解题思路:

如果两个小孩A和B, A喜欢的是B不喜欢的,或者A不喜欢的是B喜欢的,在两者之间建一条边, 代表两个人之间存在矛盾,去掉所有的矛盾的边,就可以让最多的小孩开心,就是求最大独立集。

#include <stdio.h>
#include <vector>
#include <string.h>
#include <algorithm>
#define N 550
using namespace std;

vector<int>e[N];
int p, pre[N];
bool book[N];
struct date {
	int like;
	int dislike;
}a[N];
int dfs(int u)
{
	for (int i = 0; i < e[u].size(); i++) {
		int v = e[u][i];
		if (book[v] == false) {
			book[v] = true;
			if (pre[v] == -1 || dfs(pre[v]))
			{
				pre[v] = u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i, j, n, m, u;
	char ch;
	while (scanf("%d%d%d", &n, &m, &p) != EOF)
	{
		for (i = 1; i <= p; i++)
			e[i].clear();
		for (i = 1; i <= p; i++)
		{
			getchar();
			scanf("%c%d", &ch, &u);
			if (ch == 'C')
				a[i].like = u;
			else
				a[i].like = u + n;
			scanf("%*c%c%d", &ch, &u);
			if (ch == 'C')
				a[i].dislike = u;
			else
				a[i].dislike = u + n;
			for (j = 1; j < i; j++)
			{
				if (a[i].like == a[j].dislike || a[i].dislike == a[j].like)
				{
					e[i].push_back(j);
					e[j].push_back(i);
				}
			}
		}
		int sum = 0;
		memset(pre, -1, sizeof(pre));
		for (i = 1; i <= p; i++)
		{
			memset(book, false, sizeof(book));
			if (dfs(i))
				sum++;
		}
		printf("%d\n", p - sum / 2);
	}
	return 0;
}

 

posted @ 2019-07-24 16:07  宿星  阅读(145)  评论(0编辑  收藏  举报