Live Love
https://pintia.cn/problem-sets/1036903825309761536/problems/1041155943483625472
A Live Love
DreamGrid is playing the music game Live Love. He has just finished a song consisting of n notes and got a result sequence A1,A2,...,An (Ai∈ {PERFECT, NON-PERFECT}). The score of the song is equal to the max-combo of the result sequence, which is defined as the maximum number of continuous PERFECTs in the sequence.
Formally speaking, max-combo(A)=max { k | k is an integer and there exists an integer i (1≤i≤n−k+1) such that Ai=Ai+1=Ai+2=...=Ai+k−1= PERFECT }. For completeness, we define max(∅)=0.
As DreamGrid is forgetful, he forgets the result sequence immediately after finishing the song. All he knows is the sequence length n and the total number of PERFECTs in the sequence, indicated by m. Any possible score s he may get must satisfy that there exists a sequence A′ of length n containing exactly mPERFECTs and (n−m) NON-PERFECTs and max-combo(A′)=s. Now he needs your help to find the maximum and minimum s among all possible scores.
Input
There are multiple test cases. The first line of the input contains an integer T (1≤T≤100), indicating the number of test cases. For each test case:
The only line contains two integers n and m (1≤n≤103, 0≤m≤103, m≤n), indicating the sequence length and the number of PERFECTs DreamGrid gets.
Output
For each test case output one line containing two integers smax and smin, indicating the maximum and minimum possible score.
Sample Input
5
5 4
100 50
252 52
3 0
10 10
Sample Output
4 2
50 1
52 1
0 0
10 10
Hint
Let's indicate a PERFECT as P and a NON-PERFECT as N.
For the first sample test case, the sequence (P,P,P,P,N) leads to the maximum score and the sequence (P,P,N,P,P) leads to the minimum score.
题意是给出所有的长度和perfect的个数,求可能的最大分数和最小分数,最大分数肯定是所有的perfect都连在一起的情况,最小分数是刚好所有的perfect被平均分开的情况。
#include<stdio.h>
int main()
{
int t,n,m,max,min;
scanf("%d",&t);;
while(t--)
{
scanf("%d%d",&n,&m);
max=m;
m=n-m+1;
min=n/m;
printf("%d %d\n",max,min);
}
return 0;
}