第六届河南省程序设计大赛:Card Trick
描述
The magician shuffles a small pack of cards, holds it face down and performs the following procedure:
- The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
- Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
- Three cards are moved one at a time…
- This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.
输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…
样例输入
2
4
5
样例输出
2 1 4 3
3 1 4 5 2
题意:
从牌顶取出1张牌,放在牌底,取出牌顶,为1;
从牌顶取出2张牌,放在牌底,取出牌顶,为2;
从牌顶取出3张牌,放在牌底,取出牌顶,为3;
问有n张牌想要达到目的牌最初需要怎样排列?
#include<stdio.h>
#define N 1020
int a[N];
int main()
{
int T,i,n,m,k,h,t;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
h=0;t=0;
a[t]=a[h]=n;
k=n-1;
while(k)
{
h++;
m=k;
a[h]=m;
while(m--)
{
h++;
a[h]=a[t];
t++;
}
k--;
}
for(i=h;i>=t;i--)
printf("%d ",a[i]);
printf("\n");
}
return 0;
}