hdu 4452 模拟

Running Rabbits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 534    Accepted Submission(s): 377

Problem Description
Rabbit Tom and rabbit Jerry are running in a field. The field is an N×N grid. Tom starts from the up-left cell and Jerry starts from the down-right cell. The coordinate of the up-left cell is (1,1) and the coordinate of the down-right cell is (N,N)。A 4×4 field and some coordinates of its cells are shown below:
The rabbits can run in four directions (north, south, west and east) and they run at certain speed measured by cells per hour. The rabbits can't get outside of the field. If a rabbit can't run ahead any more, it will turn around and keep running. For example, in a 5×5 grid, if a rabbit is heading west with a speed of 3 cells per hour, and it is in the (3, 2) cell now, then one hour later it will get to cell (3,3) and keep heading east. For example again, if a rabbit is in the (1,3) cell and it is heading north by speed 2,then a hour latter it will get to (3,3). The rabbits start running at 0 o'clock. If two rabbits meet in the same cell at k o'clock sharp( k can be any positive integer ), Tom will change his direction into Jerry's direction, and Jerry also will change his direction into Tom's original direction. This direction changing is before the judging of whether they should turn around. The rabbits will turn left every certain hours. For example, if Tom turns left every 2 hours, then he will turn left at 2 o'clock , 4 o'clock, 6 o'clock..etc. But if a rabbit is just about to turn left when two rabbit meet, he will forget to turn this time. Given the initial speed and directions of the two rabbits, you should figure out where are they after some time.
 
Input
There are several test cases. For each test case: The first line is an integer N, meaning that the field is an N×N grid( 2≤N≤20). The second line describes the situation of Tom. It is in format "c s t"。c is a letter indicating the initial running direction of Tom, and it can be 'W','E','N' or 'S' standing for west, east, north or south. s is Tom's speed( 1≤s<N). t means that Tom should turn left every t hours( 1≤ t ≤1000). The third line is about Jerry and it's in the same format as the second line. The last line is an integer K meaning that you should calculate the position of Tom and Jerry at K o'clock( 1 ≤ K ≤ 200). The input ends with N = 0.
 
Output
For each test case, print Tom's position at K o'clock in a line, and then print Jerry's position in another line. The position is described by cell coordinate.
 
Sample Input
4 E 1 1 W 1 1 2 4 E 1 1 W 2 1 5 4 E 2 2 W 3 1 5 0
 
Sample Output
2 2 3 3 2 1 2 4 3 1 4 1
 
思路:一步一步模拟,注意方向,开始时不转向,互撞时交换方向不转向,撞墙时反方向
 
#include <iostream>

using namespace std;

class Point{
public:
    int x,y;
    Point(int x,int y):x(x),y(y){}
    friend bool operator==(const Point &a,const Point &b)
    {
        return a.x==b.x&&a.y==b.y;
    }
    friend ostream & operator<<(ostream &out,const Point &a)
    {
        return out<<a.x<<' '<<a.y;
    }
};

const int toReturn(const char dir)
{
    if(dir=='E') return 1;
    if(dir=='W') return 2;
    if(dir=='N') return 3;
    if(dir=='S') return 4;
    return 0;
}

void toReturn(int &dir)
{
    if(dir==1) dir=3;
    else if(dir==2) dir=4;
    else if(dir==3) dir=2;
    else if(dir==4) dir=1;
}

const int toReturn(const int dir,int )
{
    if(dir==1) return 2;
    if(dir==2) return 1;
    if(dir==3) return 4;
    if(dir==4) return 3;
}

void nextPoint(Point &p,int &dir,const int v,const int n)
{
    switch(dir)
    {
        case 1:
            p.y+=v;
            break;
        case 2:
            p.y-=v;
            break;
        case 3:
            p.x-=v;
            break;
        case 4:
            p.x+=v;
            break;
        default:
            break;
    }
    if(p.x<1)
    {
        p.x=2-p.x;
        dir=toReturn(dir,0);
    }
    if(p.y<1)
    {
        p.y=2-p.y;
        dir=toReturn(dir,0);
    }
    if(p.x>n)
    {
        p.x=2*n-p.x;
        dir=toReturn(dir,0);
    }
    if(p.y>n)
    {
        p.y=2*n-p.y;
        dir=toReturn(dir,0);
    }
}

int main()
{
    int i,n,vt,ct,vj,cj,kt,dirt,dirj;
    char dirst;
    while(cin>>n,n)
    {
        Point pt(1,1),pj(n,n);
        cin>>dirst>>vt>>ct;
        dirt=toReturn(dirst);
        cin>>dirst>>vj>>cj;
        dirj=toReturn(dirst);
        cin>>kt;
        for(i=1;i<=kt;i++)
        {
            nextPoint(pt,dirt,vt,n);
            nextPoint(pj,dirj,vj,n);
            if(pt==pj)
            {
                swap(dirt,dirj);
            }
            else
            {
                if(i%ct==0)
                    toReturn(dirt);
                if(i%cj==0)
                    toReturn(dirj);
            }
        }
        cout<<pt<<endl;
        cout<<pj<<endl;
    }
    return 0;
}

 

posted @ 2013-07-17 18:01  zyh123101  阅读(244)  评论(0编辑  收藏  举报