排序(算法竞赛进阶指南)
给定 n 个变量和 m 个不等式。其中 n 小于等于 26,变量分别用前 n 的大写英文字母表示。
不等式之间具有传递性,即若 A>B 且 B>C,则 A>C。
请从前往后遍历每对关系,每次遍历时判断:
如果能够确定全部关系且无矛盾,则结束循环,输出确定的次序;
如果发生矛盾,则结束循环,输出有矛盾;
如果循环结束时没有发生上述两种情况,则输出无定解。
输入格式
输入包含多组测试数据。
每组测试数据,第一行包含两个整数 n 和 m。
接下来 m 行,每行包含一个不等式,不等式全部为小于关系。
当输入一行 0 0 时,表示输入终止。
输出格式
每组数据输出一个占一行的结果。
结果可能为下列三种之一:
如果可以确定两两之间的关系,则输出 "Sorted sequence determined after t relations: yyy...y.",其中't'指迭代次数,'yyy...y'是指升序排列的所有变量。
如果有矛盾,则输出: "Inconsistency found after t relations.",其中't'指迭代次数。
如果没有矛盾,且不能确定两两之间的关系,则输出 "Sorted sequence cannot be determined."。
数据范围
2≤n≤26,变量只可能为大写字母 A∼Z。
输入样例1:
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
输出样例1:
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
输入样例2:
6 6
A<F
B<D
C<E
F<D
D<E
E<F
0 0
输出样例2:
Inconsistency found after 6 relations.
输入样例3:
5 5
A<B
B<C
C<D
D<E
E<A
0 0
输出样例3:
Sorted sequence determined after 4 relations: ABCDE.
选择算法:
因为这道题的关系只有相对大小,不存在收敛这一说,spfa,dijkstra应该不行吧。
这题我们需要用到不等式的传递性,即A < B,B < C,则A < C这个格式像什么······
实质是用了一个中间量建立了原来不存在的关系。
由此我们得出结论
floyd 算法的另外一个用途:判断两点之间是否可以到达!
这些想法是看了AcWing 343. 排序(仅用 Floyd !详解) - AcWing(超级好)
得来的。
具体细节:
我们观察到原题中:接下来 m 行,每行包含一个不等式,不等式全部为小于关系。
于是用dist[x][y]来表示x,y(先把字母换成数字)的关系,若dist == inf则无法确立x > y,反之则说明
x > y。
1.当dist[x][y] != inf且dist[y][x] != inf时,则出现矛盾
2.若有唯一解,则一定能在m次内排出完整的关系,所以超过m次还未跳出循环则有多解
3.我们要知道一个点的具体关系(它是第几名),只要满足 比他成绩好的人数 + 没他成绩好的人数总和 = 总人数(除自己)所以我们只需把它放到ans数组下标i,或是记录他们的名次(比多少个字母大为关键字排序)
4.根据不等式传递性得知
void floyd(int x) //以 x 为中转点,更新其他点。
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
dist[i][j] = min(dist[i][j], dist[i][x] + dist[x][j]);
}
代码
#include<bits/stdc++.h>
using namespace std;
typedef pair<int,int> PII;
#define x first
#define y second
map<int,int> mp;
const int N = 210, mod = 1e9+7;
int T, n, m, k;
int a[N], dist[N][N];
PII ans[N];
void floyd(int x) //以 x 为中转点,更新其他点。
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
dist[i][j] = min(dist[i][j], dist[i][x] + dist[x][j]);
}
bool pd() //判断是否所有点都已确定
{
for(int i=1;i<=n;i++)
{
int cnt=0;
for(int j=1;j<=n;j++) if(dist[i][j]!=1e9) cnt++; //当前点能到达的点数
ans[i] = {cnt, i};
for(int j=1;j<=n;j++) if(i!=j && dist[j][i]!=1e9) cnt++; //能到达当前点的点数
if(cnt!=n) return 0;
}
sort(ans+1, ans+n+1);
return 1;
}
int main(){
while(cin>>n>>m && n)
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(i!=j) dist[i][j] = 1e9;
int flag=0;
for(int i=1;i<=m;i++)
{
char a, t, b;cin>>a>>t>>b;
int x = a-'A'+1, y = b-'A'+1; //现在要加一条从 y 到 x 的边
if(!flag && dist[x][y] != 1e9) //发现已经从x能到y,出现矛盾
{
printf("Inconsistency found after %d relations.\n", i);
flag=1;
}
dist[y][x] = 1;
floyd(x), floyd(y); //分别以 x 和 y 为中转点更新其他点
if(!flag && pd()){ //发现所有点都已确定
printf("Sorted sequence determined after %d relations: ", i);
for(int i=1;i<=n;i++) cout<<char(ans[i].y+'A'-1);
printf(".\n");
flag=1;
}
}
if(!flag) printf("Sorted sequence cannot be determined.\n"); //无法确定
}
return 0;
}