HDU 3949 XOR 线性基

XOR

Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 
Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 
Sample Input
2 2 1 2 4 1 2 3 4 3 1 2 3 5 1 2 3 4 5

 

Sample Output
Case #1: 1 2 3 -1 Case #2: 0 1 2 3 -1
Hint
If you choose a single number, the result you get is the number you choose. Using long long instead of int because of the result may exceed 2^31-1.
 

题意:

  给你n个数,你可以任选至少一个数异或起来得到一个值,Q个询问,每次询问你第k小的异或值是多少

  矩阵是如此奇妙

#include<bits/stdc++.h>
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
#define ls i<<1
#define rs ls | 1
#define mid ((ll+rr)>>1)
#define pii pair<int,int>
#define MP make_pair
typedef long long LL;
const long long INF = 1e18+1LL;
const double Pi = acos(-1.0);
const int N = 1e5+10, M = 1e3+20, mod = 1e9+7, inf = 2e9;

int T,cas = 1,Q,n,OK;
unsigned long long  p[N],ins[N],x,k,a[N];
void init() {
    x = 0,OK = 0;
    memset(ins,0,sizeof(ins));
    for(int i = 1; i <= n; ++i) {
        for(int j = 62; j >= 0; --j) {
            if(a[i]&(1LL<<j)) {
                if(!ins[j]) {
                    ins[j] = a[i];
                    break;
                }
                a[i] ^= ins[j];
            }
        }
        if(a[i] == 0) OK = 1;
    }
    for(int i = 62; i >= 0; --i) {
        for(int j = i-1; j >= 0; --j) {
            if(ins[i]&(1LL<<j))
                ins[i] ^= ins[j];
        }
    }
    for(int i = 0; i <= 62; ++i) {
        if(ins[i]) p[x++] = ins[i];
    }
}
int main() {
    scanf("%d",&T);
    while(T--) {
        printf("Case #%d:\n",cas++);
        scanf("%d",&n);
        for(int i = 1; i <= n; ++i) scanf("%lld",&a[i]);
        init();
        scanf("%d",&Q);
        while(Q--) {
            scanf("%lld",&k);
            LL ans = 0;
            if(OK) k--;
            if(k >= (1LL<<x)) puts("-1");
            else {
                for(int i = 62; i >= 0; --i)
                    if(k&(1LL<<i))
                     ans ^= p[i];
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}

 

posted @ 2017-04-06 17:16  meekyan  阅读(200)  评论(0编辑  收藏  举报