HDU 5475An easy problem 离线set/线段树

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

 

Input
The first line is an integer T(1T10), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1Q105,1M109)
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. (0<y109)
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

 

Sample Input
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

 

Sample Output
Case #1: 2 1 2 20 10 1 6 42 504 84
 

 

Source
 
 
题解:考虑到取摸,离线做
或者线段树上搞
///1085422276
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<cmath>
#include<map>
#include<bitset>
#include<set>
#include<vector>
using namespace std ;
typedef long long ll;
#define mem(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,127,sizeof(a));
#define TS printf("111111\n");
#define FOR(i,a,b) for( int i=a;i<=b;i++)
#define FORJ(i,a,b) for(int i=a;i>=b;i--)
#define READ(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define mod 1000000007
#define inf 100000
inline ll read()
{
    ll x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}
//****************************************
struct ss
{
    int id,x;
    bool operator < (const ss &A)const
    {
        return id < A.id;
    }
};
#define maxn 100000+5
set<ss >s;
set<ss >::iterator it;
int main()
{
    int oo=1;
    ll n,q,m,x[maxn],op[maxn],vis[maxn],ans[maxn],A[maxn];
    int T=read();
    while(T--)
    {
        scanf("%I64d%I64d",&n,&m);
        FOR(i,1,n)
        {
            scanf("%I64d%I64d",&op[i],&x[i]);
        }
        mem(vis);
        FOR(i,1,n)
        {
            if(op[i]==2)vis[x[i]]=1;
        }
        mem(ans);
        ans[0]=1;
        FOR(i,1,n)
        {
            ans[i]=ans[i-1];
            if(op[i]==1&&!vis[i])
            {
                ans[i]=(ans[i]*x[i])%m;
            }
        }
        //cout<<ans[10]<<endl;
        s.clear();
        for(int i=n; i>=1; i--)
        {
            ll tmp=1;
            for(it=s.begin(); it!=s.end(); it++)
            {
                if((*it).id>i)break;
                tmp*=(*it).x;
                tmp%=m;
            }
            A[i]=(ans[i]*tmp)%m;
            if(op[i]==2)
            {
                ss g;
                g.id=x[i];
                g.x=x[x[i]];
                s.insert(g);
            }
        }
        printf("Case #%d:\n",oo++);
        for(int i=1; i<=n; i++)
            cout<<A[i]<<endl;
    }
    return 0;
}
代码

 

 

 

posted @ 2015-09-30 01:06  meekyan  阅读(219)  评论(0编辑  收藏  举报