PAT乙级1058

批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

输入格式:

输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:

按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple

输入样例:

3 4 
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)

输出样例:

3
6
5
2 2 3 4

 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<cmath>
#include <vector>
using namespace std;
//3 2 5 1
//1 0 0 0  3
//1 1 0 1  6
//0 0 1 0  5
struct sco
{
    int score;
    int right;
    char r[6];
    int wrong;
};
int n,m,maxerrors;
int main() {
    cin >> n >> m;
    sco sco1[m];
    int num;
    for (int i = 0; i < m; i++) {
        cin >> sco1[i].score;
        cin >> num >> sco1[i].right;
    sco1[i].wrong = 0;
    char c;
    int j=0;
    while((c=getchar())!='\n')
    {
        if(isalpha(c)){
            sco1[i].r[j]=c;
            j++;
        }
    }
    sco1[i].r[j]='\0';
}

    //string str;

    for (int i = 0; i < n; ++i) {
        int grade = 0, cnt;
        char c, choose[6];
        for (int j = 0; j < m; j++) {
            cin >> cnt;
            int k = 0;
            while ((c = getchar()) != ')') {
                if (isalpha(c)) {
                    choose[k++] = c;
                }
            }
            choose[k] = '\0';

            if (strcmp(choose, sco1[j].r) == 0)
                grade += sco1[j].score;
            else
                sco1[j].wrong++;
            if (maxerrors < sco1[j].wrong) {
                maxerrors = sco1[j].wrong;
            }
        }
        cout << grade << endl;
    }
        if(maxerrors==0)
            printf("Too simple");
        else
        {
            printf("%d",maxerrors);
            for(int i=0;i<m;i++){
                if(sco1[i].wrong==maxerrors)
                    printf(" %d",i+1);
            }
        }
    return 0;
}

 

把每一道题看作一个结构体

posted @ 2019-08-14 00:04  zuiaimiusi  阅读(189)  评论(0编辑  收藏  举报