PAT 1004 To Fill or Not to Fill (25)

题目描写叙述

With highways available, driving a car from Hangzhou to any other city is easy.  But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time.  Different gas station may give different price.  You are asked to carefully design the cheapest route to go.

输入描写叙述:

Each input file contains one test case.  For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations.  Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N.  All the numbers in a line are separated by a space.


输出描写叙述:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places.  It is assumed that the tank is empty at the beginning.  If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

输入样例:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

输出样例:

749.17



#include <iostream>
#include <cstdio>
#include <algorithm>
#include <climits>

using namespace std;

typedef struct Node
{
	double price;
	double distance;
}Node;

bool cmp(const Node& lhs, const Node& rhs)
{
	return lhs.distance<rhs.distance;
}

int main()
{
	double Cm,D,cur,cost,minCost,maxDistance;
	int Da,N;
	int i,j,k,l,ans;
	while(cin>>Cm>>D>>Da>>N)
	{
		maxDistance=Cm*Da;
		Node *node=new Node[N+1];
		for(i=0;i<N;i++)
			cin>>node[i].price>>node[i].distance;

		sort(node,node+N,cmp);

		node[N].price=0;
		node[N].distance=D;

		ans=cur=cost=0;
		for(i=0;i<N-1;i++)
		{
			if((node[i+1].distance-node[i].distance)>maxDistance)
				break;
		}
		if(i<N-1)
		{
			printf("The maximum travel distance = %.2lf\n",node[i].distance+maxDistance);
		}
		else
		{
			for(i=0;i<N;)
			{

				//后面假设有比当前更廉价的汽油,如今先少弄点,够到那个地方就OK				
				l=i;
				minCost=node[i].price;
				for(j=i+1;j<=N && (node[i].distance+maxDistance>=node[j].distance);j++)
				{
					if(minCost>node[j].price)
					{
						l=j;
						break;
					}
				}
				if(l!=i)
				{
					cost=cost+((node[l].distance-node[i].distance)/Da-cur)*node[i].price;
					cur=0;
					i=l;
					continue;
				}
				//假设找不到更廉价的加油站。找出相对最廉价的加油站。而且在当前加油站加满油
				l=i;
				minCost=1e18;
				for(j=i+1;j<=N && (node[i].distance+maxDistance>=node[j].distance);j++)
				{
					if(minCost>node[j].price)
					{
						minCost=node[j].price;
						l=j;
					}
				}
				cost=cost+(Cm-cur)*node[i].price;
				cur=Cm-(node[l].distance-node[i].distance)/Da;
				i=l;
			}
			printf("%.2lf",cost);
		}			
/*

		for(i=0;i<N;i++)
			cout<<node[i].price<<" "<<node[i].distance<<endl;

*/
	}
	return 0;
}


贴个图




posted @ 2017-06-04 20:46  zsychanpin  阅读(95)  评论(0编辑  收藏  举报