Sweety

Practice makes perfect

导航

HDU 5971 Wrestling Match(染色法二分图 OR 并查集)

Posted on 2017-05-03 21:12  蓝空  阅读(191)  评论(0编辑  收藏  举报

Wrestling Match

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1103    Accepted Submission(s): 421


Problem Description
Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".
 

Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.
 

Output
If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".
 

Sample Input
5 4 0 0 1 3 1 4 3 5 4 5 5 4 1 0 1 3 1 4 3 5 4 5 2
 

Sample Output
NO YES
 

Source
 

Recommend
wange2014


染色法判断二分图!!!

简单题

不过边忘*2,TL了两发,不过话说为什么是TL不应该是RuntimeError么

貌似并查集好像也可以。。。

#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;

#define MAXN 1005//点数
#define MAXM 20005//边数

int color[MAXN];

struct Edge
{
  int to,next;
}edge[MAXM];

int head[MAXN];
int tot;
bool ans;///结果

void addedge(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}

void init(int n)
{
    tot=0;
    memset(head,-1,sizeof(int)*(n+10));
    memset(color,0,sizeof(int)*(n+10));
}

bool dfs(int u) ///dfs交叉染色,两种颜色标记为 1 和 -1,未染色标记为 0
{
    int v;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        v=edge[i].to;
        if(color[v]==0) ///未染色
        {
            color[v]=(color[u]==1 ? -1 : 1);
            if(!dfs(v)) return false; ///不能交叉染色
        }
        else ///已染色
        {
            if(color[v]==color[u]) ///不能交叉染色
                return false;
        }
    }
    return true;
}

int main()
{

    int n,L;
    int u,v;

    int good , bad ,rela ,tmp;
    while(~scanf("%d%d%d%d",&n,&rela,&good,&bad))
    {
        init(n);
        for(int i=0; i<rela; ++i)
            scanf("%d%d",&u,&v), addedge(u,v),addedge(v,u);
        for(int i=0; i<good; i++)
            scanf("%d",&tmp),color[tmp]=1;
        for(int i=0; i<bad; i++)
            scanf("%d",&tmp),color[tmp]=-1;

        ans = 1;
        for(int i=1; i<=n && ans; i++)
            if(color[i]!=0)
                ans&=dfs(i);

        for(int i=1; i<=n && ans; i++)
        {
            if(color[i]==0)
            {
                if(head[i]==-1)
                    ans=0;
                else
                {
                    color[i]=1;
                    ans&=dfs(i);
                }
            }
        }
        printf("%s\n",ans?"YES":"NO");
    }
    return 0;
}