Sweety

Practice makes perfect
随笔 - 620, 文章 - 0, 评论 - 2, 阅读 - 20万

导航

< 2025年2月 >
26 27 28 29 30 31 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 1
2 3 4 5 6 7 8

Shopping(山东省第一届ACM省赛)

Posted on   蓝空  阅读(204)  评论(0编辑  收藏  举报

Shopping

Time Limit: 1000MS Memory limit: 65536K

题目描述

Saya and Kudo go shopping together.
You can assume the street as a straight line, while the shops are some points on the line.
They park their car at the leftmost shop, visit all the shops from left to right, and go back to their car.
Your task is to calculate the length of their route.

输入

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N<100001), represents the number of shops.
The next line contains N integers, describing the situation of the shops. You can assume that the situations of the shops are non-negative integer and smaller than 2^30.
The last case is followed by a line containing one zero.

输出

 For each test case, print the length of their shopping route.

示例输入

4
24 13 89 37
6
7 30 41 14 39 42
0

示例输出

152
70

提示

Explanation for the first sample: They park their car at shop 13; go to shop 24, 37 and 89 and finally return to shop 13. The total length is (24-13) + (37-24) + (89-37) + (89-13) = 152

来源

 2010年山东省第一届ACM大学生程序设计竞赛

链接:http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2154

水题  排序

#include <iostream> 
#include <cstring> 
#include <cstdio> 
#include <string> 
#include <algorithm> 
#include <cmath> 
#define MAX 100005 
#define LL long long 
using namespace std; 
int main() 
    int n; 
    int a[MAX]; 
    while(~scanf("%d",&n)&&n!=0){ 
        for(int i=0;i<n;i++){ 
            scanf("%d",&a[i]); 
        
        sort(a,a+n); 
        LL sum=0; 
        for(int i=1;i<n;i++) 
            sum+=(a[i]-a[i-1]); 
        sum+=(a[n-1]-a[0]); 
        printf("%lld\n",sum); 
    
    return 0; 

  

编辑推荐:
· 开发中对象命名的一点思考
· .NET Core内存结构体系(Windows环境)底层原理浅谈
· C# 深度学习:对抗生成网络(GAN)训练头像生成模型
· .NET 适配 HarmonyOS 进展
· .NET 进程 stackoverflow异常后,还可以接收 TCP 连接请求吗?
阅读排行:
· 本地部署 DeepSeek:小白也能轻松搞定!
· 基于DeepSeek R1 满血版大模型的个人知识库,回答都源自对你专属文件的深度学习。
· 在缓慢中沉淀,在挑战中重生!2024个人总结!
· 大人,时代变了! 赶快把自有业务的本地AI“模型”训练起来!
· Tinyfox 简易教程-1:Hello World!
历史上的今天:
2015-04-25 蓝桥杯---最大子阵
2015-04-25 无穷大技巧设置
2015-04-25 蓝桥杯---蚂蚁感冒(水题)
点击右上角即可分享
微信分享提示