Sweety

Practice makes perfect
随笔 - 620, 文章 - 0, 评论 - 2, 阅读 - 20万

导航

< 2025年2月 >
26 27 28 29 30 31 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 1
2 3 4 5 6 7 8

A - Oulipo(KMP算法经典)

Posted on   蓝空  阅读(312)  评论(0编辑  收藏  举报

 

 

详细KMP见http://blog.csdn.net/u014665013/article/details/37995355

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A','B','C', …, 'Z'} and two finite strings over that alphabet, a wordW and a textT, count the number of occurrences of W inT. All the consecutive characters of W must exactly match consecutive characters ofT. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B','C', …,'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the stringW).
  • One line with the text T, a string over {'A', 'B','C', …,'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the wordW in the textT.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题意:

找出在目标串中有多少模式串(相邻两串中可以重叠)

代码

#include <stdio.h>
#include <string.h>
int next[10005];
char str1[1000005],str2[10005];
void getnext(int len)//此处也可以将int next[]改写成  int* next[]
{
	int j,k;
	j=0; k=-1; next[0]=-1;
	while(j<len){
		if(k==-1 ||str2[j]==str2[k]){
			j++;
			k++;
			next[j]=k;
		}
		else k=next[k];
	}
}
int kmp(int len1,int len2)//kmp算法
{
	int count=0;
    int i=0,j=0;
    getnext(len2);
    while(i<len1)
    {
        if(j==-1||str1[i]==str2[j]){
          ++i;
          ++j;   //j控制子串回溯和遍历 
        }
        else
         j=next[j];
        if(j == len2){
            count++;
            j = next[j];   //当有一个匹配成功的时候,相当于匹配失败,重新定位子串的匹配位置 
        }
    }
  return  count; 
}
int main()
{
    int Case;
    int len1,len2;
    scanf("%d",&Case);
    getchar();//注意吸收空格 
    while(Case--)
    {
        gets(str2);
        gets(str1);
        len1 = strlen(str1), len2 = strlen(str2);
        printf("%d\n",kmp(len1,len2));
    }
    return 0;
}




编辑推荐:
· 用 C# 插值字符串处理器写一个 sscanf
· Java 中堆内存和栈内存上的数据分布和特点
· 开发中对象命名的一点思考
· .NET Core内存结构体系(Windows环境)底层原理浅谈
· C# 深度学习:对抗生成网络(GAN)训练头像生成模型
阅读排行:
· 手把手教你更优雅的享受 DeepSeek
· AI工具推荐:领先的开源 AI 代码助手——Continue
· 探秘Transformer系列之(2)---总体架构
· V-Control:一个基于 .NET MAUI 的开箱即用的UI组件库
· 乌龟冬眠箱湿度监控系统和AI辅助建议功能的实现
点击右上角即可分享
微信分享提示