hdu 2141 Can you find it?

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
 
Sample Output
Case 1:
NO
YES
NO
View Code
#include"stdio.h"   
#include"string.h"   
#include"stdlib.h"   
  
int tot[3];  
int x[511];  
int y[511];  
int z[511];  
int d[251111],k;  
  
int cmp(const void *a,const void *b)  
{  
    return *(int *)a-*(int *)b;  
}  
int main()  
{  
    int Case=1,n;  
    int i,l;  
    int aim,temp,flag;  
    int low,up,mid;  
  
    while(scanf("%d%d%d",&tot[0],&tot[1],&tot[2])!=-1)  
    {  
        qsort(tot,3,sizeof(tot[0]),cmp);  
        for(i=0;i<tot[0];i++)    scanf("%d",&x[i]);  
        for(i=0;i<tot[1];i++)    scanf("%d",&y[i]);  
        for(i=0;i<tot[2];i++)    scanf("%d",&z[i]);  
        qsort(x,tot[0],sizeof(x[0]),cmp);  
  
        k=0;  
        for(i=0;i<tot[1];i++)  
        for(l=0;l<tot[2];l++)  
            d[k++]=y[i]+z[l];  
        qsort(d,k,sizeof(d[0]),cmp);  
  
        scanf("%d",&n);  
        printf("Case %d:\n",Case++);  
        while(n--)  
        {  
            scanf("%d",&aim);  
            flag=0;  
            for(i=0;i<tot[0];i++)  
            {  
                temp=aim-x[i];  
  
                low=0;up=k-1;mid=(low+up)/2;  
                while(up-low>1)  
                {  
                    if(d[mid]>temp)      up=mid;  
                    else if(d[mid]<temp)low=mid;  
                    else                {flag=1;break;}  
                    mid=(low+up)/2;  
                }  
                if(d[low]==temp || d[up]==temp) flag=1;  
  
                if(flag)    break;  
            }  
            if(flag)    printf("YES\n");  
            else        printf("NO\n");  
        }  
    }  
    return 0;  
}  

 

posted @ 2013-04-21 19:33  zlyblog  阅读(347)  评论(0编辑  收藏  举报