PAT 甲级 1028 List Sorting

https://pintia.cn/problem-sets/994805342720868352/problems/994805468327690240

 

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int N, C;

struct Node {
    int id;
    char name[30];
    int score;
}node[maxn];

bool cmp1(const Node& a, const Node& b) {
    return a.id < b.id;
}

bool cmp2(const Node& a, const Node& b) {
    if(strcmp(a.name, b.name))
        return strcmp(a.name, b.name) < 0;
    else
        return a.score > b.score;
}

bool cmp3(const Node& a, const Node& b) {
    if(a.score != b.score)
        return a.score < b.score;
    else
        return a.id < b.id;
}


int main() {
    while(~scanf("%d%d", &N, &C)) {
        for(int i = 1; i <= N; i ++)
        scanf("%d%s%d", &node[i].id, node[i].name, &node[i].score);

        if(C == 1)
            sort(node + 1, node + 1 + N, cmp1);
        if(C == 2)
            sort(node + 1, node + 1 + N, cmp2);
        if(C == 3)
            sort(node + 1, node + 1 + N, cmp3);

        for(int i = 1; i <= N; i ++)
            printf("%06d %s %d\n", node[i].id, node[i].name, node[i].score);
    }
    return 0;
}

  

posted @ 2018-10-24 09:49  丧心病狂工科女  阅读(85)  评论(0编辑  收藏  举报