HDU 2131 Probability

http://acm.hdu.edu.cn/showproblem.php?pid=2131

 

Problem Description
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
 
Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
 
Output
For each test case, print the probability rounded to five digits after the decimal point.
 
Sample Input
a apple
c Candy
a banana
 
Sample Output
0.20000
0.20000
0.50000
 
代码:
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
char s[maxn];
char c;

int main() {
    while(~scanf("%c%s", &c, s)) {
        getchar();
        int len = strlen(s);
        int cnt = 0;
        for(int i = 0; i< len; i ++) {
            if(s[i] == c || s[i] == c - 32 || s[i] == c + 32)
                cnt ++;
        }
        printf("%.5lf\n", 1.0 * cnt / len);
    }
    return 0;
}

  

posted @ 2018-09-20 16:15  丧心病狂工科女  阅读(185)  评论(0编辑  收藏  举报