HDU 2602 Bone Collector

http://acm.hdu.edu.cn/showproblem.php?pid=2602

 

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
代码:
#include <bits/stdc++.h>
using namespace std;

int N, V;
int w[1111], v[1111];
int dp[1111][1111];

void solve() {
    for(int i = 0; i < N; i ++) {
        for(int j = 0; j <= V; j ++) {
            if(j < w[i])
                dp[i + 1][j] = dp[i][j];
            else
                dp[i + 1][j] = max(dp[i][j], dp[i][j - w[i]] + v[i]);
        }
    }
    printf("%d\n", dp[N][V]);
}

int main() {
    int T;
    scanf("%d", &T);
    while(T --) {
        memset(dp, 0, sizeof(dp));
        scanf("%d%d", &N, &V);
        for(int i = 0; i < N; i ++)
            scanf("%d", &v[i]);
        for(int i = 0; i < N; i ++)
            scanf("%d", &w[i]);

        solve();
    }
    return 0;
}

  

posted @ 2018-09-06 10:40  丧心病狂工科女  阅读(89)  评论(0编辑  收藏  举报