HDU 2006 求奇数的乘积

http://acm.hdu.edu.cn/showproblem.php?pid=2006

 

Problem Description
给你n个整数,求他们中所有奇数的乘积。
 
Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。
 
Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。
 
Sample Input
3 1 2 3 4 2 3 4 5
 
Sample Output
3 15
 
代码:
#include <bits/stdc++.h>

using namespace std;


int main()
{
    int n;
    while(cin>>n)
    {
        int sum=1;
        for(int i=1; i<=n; i++)
        {
            int x;
            cin>>x;
            if(x%2!=0)
                sum*=x;
        }
        cout<<sum<<endl;
    }
    return 0;
}

  

 

posted @ 2018-06-21 09:09  丧心病狂工科女  阅读(87)  评论(0编辑  收藏  举报