POJ 3461 Oulipo

http://poj.org/problem?id=3461

 

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 1e7 + 5;
int TT;
int nx[maxn];
char S[maxn], T[maxn];
int slen, tlen;

void getNext() {
    int j, k;
    j = 0, k = -1, nx[0] = -1;
    while(j < tlen) {
        if(k == -1 || T[j] == T[k])
            nx[++ j] = ++ k;
        else k = nx[k];
    }
}

int KMP_Count() {
    int ans = 0;
    int i = 0, j = 0;

    if(slen == 1 && tlen == 1) {
        if(S[0] == T[0])
            return 1;
        else return 0;
    }

    getNext();

    for(int i = 0; i < slen; i ++) {
        while(j > 0 && S[i] != T[j])
            j = nx[j];

        if(S[i] == T[j])
            j ++;
        if(j == tlen) {
            ans ++;
            j = nx[j];
        }
    }
    return ans;
}

int main() {
    scanf("%d", &TT);
    while(TT --) {
        scanf("%s%s", T, S);
        slen = strlen(S);
        tlen = strlen(T);

        printf("%d\n", KMP_Count());
    }
    return 0;
}

  KMP 模板 求模式串在主串中出现的次数

posted @ 2019-03-27 11:54  丧心病狂工科女  阅读(200)  评论(0编辑  收藏  举报