PAT 甲级 1085 Perfect Sequence

https://pintia.cn/problem-sets/994805342720868352/problems/994805381845336064

 

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if Mm×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (105​​) is the number of integers in the sequence, and p (109​​) is the parameter. In the second line there are N positive integers, each is no greater than 109​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
 

代码:

    #include <bits/stdc++.h>
using namespace std;
 
const int maxn = 1e5 + 10;
long long a[maxn];
 
int main() {
    int N, p, temp = 1;
    scanf("%d%d", &N, &p);
    for(int i = 1; i <= N; i ++)
        scanf("%lld", &a[i]);
    sort(a + 1, a + 1 + N);
    for(int i = 1; i <= N; i ++) {
        for(int j = temp + i; j <= N; j ++) {
            if(a[j] <= a[i] * p)
                temp = j - i + 1;
            else break;
        }
    }
    printf("%d\n", temp);
    return 0;
}

  暴力 离考试越来越近 心慌慌

 

posted @ 2019-02-12 11:08  丧心病狂工科女  阅读(307)  评论(0编辑  收藏  举报