HDU 1059 Dividing

http://acm.hdu.edu.cn/showproblem.php?pid=1059

 

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 
Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
 
Sample Output
Collection #1: Can't be divided.
Collection #2: Can be divided.

代码:

#include <bits/stdc++.h>
using namespace std;

int v[10];
int dp[120010];
int sum;

void ZeroOnePack(int cost, int weight) {
    for(int i = sum; i >= cost; i --)
        dp[i] = max(dp[i], dp[i - cost] + weight);
}

void CompletePack(int cost, int weight) {
    for(int i = cost; i <= sum; i ++)
        dp[i] = max(dp[i], dp[i - cost] + weight);
}

void MultiplePack(int cost, int weight, int amount) {
    if(amount * cost >= sum) CompletePack(cost, weight);
    else {
        int k = 1;
        while(k < amount) {
            ZeroOnePack(k * cost, k * weight);
            amount -= k;
            k <<= 1;
        }
        ZeroOnePack(amount * cost, amount * weight);
    }
}

int main() {
    int cnt = 0;
    while(~scanf("%d", &v[1])) {
        cnt ++;
        bool flag = true;
        sum = v[1];
        for(int i = 2; i < 7; i ++) {
            scanf("%d", &v[i]);
            sum += i * v[i];
        }

        if(sum == 0) break;
        else if(sum % 2 != 0)
            flag = false;
        else {
            sum /= 2;
            memset(dp, 0, sizeof(dp));
            for(int i = 1; i <= 6; i ++)
                MultiplePack(i, i, v[i]);
            if(dp[sum] == sum) flag = true;
            else flag = false;
        }
        printf("Collection #%d:\n", cnt);
        if(flag) printf("Can be divided.\n\n");
        else printf("Can't be divided.\n\n");
    }
    return 0;
}

  多重背包 之前在 Kuangbin 的搜索专题中见到过用 好像一直没写过 长见识了 最近是和背包作斗争的小可怜

posted @ 2018-12-21 14:18  丧心病狂工科女  阅读(156)  评论(0编辑  收藏  举报