POJ1797 Heavy Transportation

                                                                                Heavy Transportation
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 15595   Accepted: 4057

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany
 
 
思路:给出含有N个点的无向图,以及点之间的权重(可以看做通过量),点从1开始编号,然后求从点1到点N的最大的通过量。
       可以运用DIJKSTRA的变形来求解。
 
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#define MAXINT 99999999

#define MININT -1

using namespace std;



int data[1000+1][1000+1];
int vis[1000+1];
int lowcost[1000+1];
int d[1000+1];


int minn(int x,int y)
{
    if(x>y)
    return y;
    return x;
}






int main()
{
    
    int n,m;
    int i,j,k;
    int t;
    
    scanf("%d",&t);
    getchar();
    int tt;
    for(tt=1;tt<=t;tt++)
    {
                        scanf("%d%d",&n,&m);
                        getchar();
                        
                        for(i=1;i<=n;i++)
                        for(j=1;j<=n;j++)
                        data[i][j]=MININT;
                        
                        for(i=0;i<m;i++)
                        {
                                        int a,b,c;
                                        scanf("%d%d%d",&a,&b,&c);
                                        
                                        if(c>data[a][b])
                                        data[b][a]=data[a][b]=c;
                                        
                        }
                        
                        
                        for(i=1;i<=n;i++)
                        {lowcost[i]=data[1][i];vis[i]=0;}
                        
                        vis[1]=1;
                        
                        for(i=1;i<n;i++)
                        {
                                        int maxcost=MININT;
                                        k=-1;
                                        
                                        for(j=1;j<=n;j++)
                                        {
                                                         if((vis[j]==0)&&(maxcost<lowcost[j]))
                                                         {k=j;maxcost=lowcost[j];}
                                        }
                                        
                                        vis[k]=1;
                                        
                                        for(j=1;j<=n;j++)
                                        {
                                                         if(vis[j]==0)
                                                         {
                                                                      int tmp=minn(lowcost[k],data[k][j]);
                                                                      if(tmp>lowcost[j])
                                                                      lowcost[j]=tmp;
                                                         }
                                                                      
                                                       
                                        }
                                        
                                        
                        }
                        
                        
                        
                        
                        
                        printf("Scenario #%d:\n",tt);
                        printf("%d\n\n",lowcost[n]);
    }
                        
                                        
                                        
    
   // system("PAUSE");
    
    return 0;
}

 

 
posted @ 2012-08-07 21:31  cseriscser  阅读(170)  评论(0编辑  收藏  举报