UVa 1585 Score 得分 题解

英文

Description

There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problem
and an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself and
its just previous consecutive ‘O’s only when the answer is correct. For example, the score of the 10th
problem is 3 that is obtained by itself and its two previous consecutive ‘O’s.
Therefore, the score of “OOXXOXXOOO” is 10 which is calculated by “1+2+0+0+1+0+0+1+2+3”.
You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case starts with a line containing a string
composed by ‘O’ and ‘X’ and the length of the string is more than 0 and less than 80. There is no spaces
between ‘O’ and ‘X’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to
contain the score of the test case.

Sample Input

5
OOXXOXXOOO
OOXXOOXXOO
OXOXOXOXOXOXOX
OOOOOOOOOO
OOOOXOOOOXOOOOX

Sample Output

10
9
7
55
30

中文

题目大意:

给出一个由O和X组成的串(长度为1~80),得分统计。每个O的得分为目前连续出现的O的个数,X的得分为0 。例如,OOXXOXXOOO的得分为1+2+0+0+1+0+0+1+2+3 。

提示:

老老实实的模拟吧…

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#define N 100001
using namespace std;
int T;
char c[N][81];
bool bo;
int main() 
{
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        long long t=0,outp=0;
        scanf("%s",c[i]);
        for(int j=0;j<strlen(c[i]);j++)
        {
            if(c[i][j]=='O') t++;
            else t=0;
            outp+=t;
        }
        printf("%lld\n",outp);
    }
    return 0;
}

相关链接:

UVa题解小全:
https://blog.csdn.net/zj_mrz/article/details/81144019

UVa 1225 Digit Counting 题解:
https://blog.csdn.net/zj_mrz/article/details/81207879

UVa 1586 Molar mass 分子量 题解:
https://blog.csdn.net/zj_mrz/article/details/81165988

UVa 1583 Digit Generator 生成元 题解:
https://blog.csdn.net/zj_mrz/article/details/81143855

posted @ 2018-07-21 14:09  ZJ_MRZ  阅读(318)  评论(0编辑  收藏  举报