Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4

  羡慕        羡慕            羡慕                羡慕            羡慕           羡慕

#include<stdio.h>
#include<algorithm>
using namespace std;
char map[5][5];
int dir[5][2]= {1,0,0,1,-1,0,0,-1,0,0};
int min1;
int judge()
{
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
            if(map[i][j]!=map[0][0])return 0;
    return 1;
}
void turn(int x,int y)
{
    for(int i=0; i<5; i++)
    {
        int tx=x+dir[i][0];
        int ty=y+dir[i][1];
        if(tx>=0&&tx<4&&ty>=0&&ty<4)
        {
            if(map[tx][ty]=='b')map[tx][ty]='w';
            else map[tx][ty]='b';
        }
    }
}
void dfs(int x,int y,int step)
{
    if(judge())
    {
        min1=min(min1,step);
    }
    if(x==4)return;
    turn(x,y);
    if(y<3)dfs(x,y+1,step+1);
    else dfs(x+1,0,step+1);
    turn(x,y);
    if(y<3)dfs(x,y+1,step);
    else dfs(x+1,0,step);
}
int main()
{
    for(int i=0; i<4; i++)
        scanf("%s",map[i]);
    min1=9999;
    dfs(0,0,0);
    if(min1<=16)
        printf("%d\n",min1);
    else printf("Impossible\n");
    return 0;
}




posted on 2017-07-13 16:50  zitian246  阅读(103)  评论(0编辑  收藏  举报