The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.
Input
* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
Output
* Line 1: A single integer that is the length of the longest road required to be traversed.
Sample Input
3 3
1 2 23
2 3 1000
1 3 43
Sample Output
43
Hint
OUTPUT DETAILS: 

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

        这是一个最小生成树的模板题,但为什么我第一次看成了迪杰斯特拉快哭了。。英文水平太差了,只能猜题。。一看到最短路最长路就当做最短路问题,又顺手拿出了dijkstra,.话说真的很像有没有,如果不放在最小生成树里,有几个人能想起来呢。杯具啊~~~下次再也不敢胡乱猜了T T.

题目大意:因为每到一个农场就可以得到补充,求最小生成树的最长边。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[2010];
struct note
{
    int u,v,w;                //习惯了这样定义结构体变量。。
}q[10010];
int cmp(note a,note b)
{
    return a.w<b.w;
}
int getf(int v)              //kruskal模板,一点都不用改。
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
int merge(int v,int u)
{
    int t1=getf(v);
    int t2=getf(u);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&q[i].u,&q[i].v,&q[i].w);
        sort(q+1,q+1+m,cmp);
        for(int i=1;i<=n;i++)
            f[i]=i;
        int s=0,k=m;
        for(int i=1;i<=m;i++)
        {
            if(merge(q[i].u,q[i].v))       //以上都是套路。。。。。
                s++;
            if(s==n-1)                   //因为排序之后,最长边肯定是最后合并的啊
            {
                k=i;                      //用K标记。。。
                break;
            }
        }
        printf("%d\n",q[k].w);
    }
    return 0;
}


posted on 2017-07-20 15:36  zitian246  阅读(116)  评论(0编辑  收藏  举报