I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

   水题也有被坑的时候

#include<stdio.h>
#include<string.h>
int main()
{
    int t;
    scanf("%d",&t);
    int f=1;
    while(t--)
    {
        int s=0,k=0;
        char a[1005],b[1005];
        int c[1005]= {0},d[1005]= {0},e[1005]= {0};
        scanf("%s%s",a,b);
        int l1=strlen(a),l2=strlen(b);
        for(int i=l1-1; i>=0; i--)
            c[s++]=a[i]-'0';
        for(int i=l2-1; i>=0; i--)
            d[k++]=b[i]-'0';
        int j=0;
        int max;
        max=l1;
        if(max<l2)max=l2;
        for(int i=0; i<=max; i++)
        {
            e[i]=c[i]+d[i]+j;
            if(e[i]>=10)
            {
                e[i]-=10;
                j=1;
            }
            else
                j=0;
        }
        printf("Case %d:\n",f++);
        printf("%s + %s = ",a,b);
        if(e[max])printf("%d",e[max]);
        for(int i=max-1; i>=0; i--)
            printf("%d",e[i]);
        if(t==0)printf("\n");
        else
            printf("\n\n");
    }
    return 0;
}


posted on 2017-08-03 14:52  zitian246  阅读(94)  评论(0编辑  收藏  举报