Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 
InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am
   题意:分别给出了单个人买票所需时间,和相邻两个人买票时间(可以看做和前面得人)。求最小时间。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int t,k;
int a[2005],b[2005];
int dp[2005];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        memset(b,0,sizeof(b));
        memset(a,0,sizeof(a));
        scanf("%d",&k);
        for(int i=1; i<=k; i++)
            scanf("%d",&a[i]);
        for(int i=2; i<=k; i++)
            scanf("%d",&b[i]);
        dp[1]=a[1];
        dp[2]=min(a[1]+a[2],b[2]);
        for(int i=3; i<=k; i++)
        {
            dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
        }
        int maxn=dp[k];
        int h,m,s;
        h=maxn/3600;
        m=(maxn%3600)/60;
        s=(maxn%3600)%60;
        h+=8;
        if(h>=12)
            printf("%02d:%02d:%02d pm\n",h,m,s);
        else
            printf("%02d:%02d:%02d am\n",h,m,s);
    }
    return 0;
}


posted on 2017-10-10 13:42  zitian246  阅读(117)  评论(0编辑  收藏  举报