操作模板:

for (int len = 1; len < n; len++) { //操作区间的长度
        for (int i = 0, j = len; j <= n; i++, j++) { //始末
            //检查是否匹配(非必须)
            for (int s = i; s < j; s++) {
                //update
            }
        }
    }

poj 2955 点击打开链接

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, imwhere 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6
题意:求能匹配的括号数,不是问所给括号是否匹配或符合要求哦:

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
char s[120];
int a[120];
int dp[120][120];
int main()
{
    while(~scanf("%s",&s))
    {
        if(strcmp(s,"end")==0)break;
        memset(dp,0,sizeof(dp));
        int l=strlen(s);
        for(int i=0; i<l; i++)
        {
            if(s[i]=='(')a[i]=1;
            if(s[i]==')')a[i]=-1;
            if(s[i]=='[')a[i]=2;
            if(s[i]==']')a[i]=-2;
        }
        for(int len=1; len<l; len++)
        {
                for(int i=0,j=len; j<l; j++,i++)
                {
                    if(a[i]+a[j]==0&&a[i]>0)
                    {
                        dp[i][j]=dp[i+1][j-1]+2;
                    }
                    for(int pos=i+1;pos<j;pos++)
                    {
                        dp[i][j]=max(dp[i][j],dp[i][pos]+dp[pos][j]);
                    }
                }
        }
        int ans=-1;
        for(int i=0;i<l;i++)
        {
            for(int j=0;j<l;j++)
            ans=max(ans,dp[i][j]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


posted on 2018-04-06 14:46  zitian246  阅读(106)  评论(0编辑  收藏  举报