题目1439:Least Common Multiple

题目1439:Least Common Multiple

时间限制:1 秒

内存限制:128 兆

特殊判题:

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105
10296
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
using namespace std;

 int gcd (int a,int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}

int lcm(int a,int b)
{
    return (a/gcd(a,b))*b;//使用了一个技巧,先除后乘,避免溢出
}

int main()
{
    int n;
    long long aim;
    while(scanf("%d",&n)!=EOF)
    {
        long long a[100];
        while(n--)
        {
            int len;
            cin>>len;
            for(int i=0; i<len; i++)
            {
                cin>>a[i];
            }
            aim=a[0];
            for(int i=0; i<len; i++)
            {
                aim=lcm(aim,a[i]);
            }
            printf("%lld\n",aim);
        }
    }
    return 0;
}

 

posted @ 2016-08-05 11:17  多思考&&多动手  阅读(234)  评论(0编辑  收藏  举报