题目1433:FatMouse

题目1433:FatMouse

时间限制:1 秒

内存限制:128 兆

特殊判题:

题目描述:

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

输入:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入:
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
样例输出:
13.333
31.500
#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
 
struct goods
{
    double j;
    double f;
    double s;
    bool operator <(const goods & A) const
    {
        return s>A.s;
    }
} buf[1000];
 
int main()
{
    double m;
    int n;
    while(scanf("%lf%d",&m,&n)!=EOF)
    {
        if(m==-1&&n==-1)
            break;
        for(int i=0; i<n; i++)
        {
            scanf("%lf %lf",&buf[i].j,&buf[i].f);
            buf[i].s=buf[i].j/buf[i].f;
        }
        sort(buf,buf+n);//按照性价比降序排序
        int idx=0;//当前货物下标
        double ans=0;//累加所得货物总重量
        while(idx<n&&m>0)//循环条件为货物还有剩余(idx<n),钱还有剩余(m>0)
        {
            if(m>buf[idx].f)
            {
                ans+=buf[idx].j;
                m-=buf[idx].f;
            }
            else
            {
                ans+=m*buf[idx].s;
                m=0;
            }
            idx++;
        }
        printf("%.3lf\n",ans);
    }
 
    return 0;
}
 
/**************************************************************
    Problem: 1433
    User: zhuoyuezai
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1544 kb
****************************************************************/

 

posted @ 2016-07-23 09:48  多思考&&多动手  阅读(166)  评论(0编辑  收藏  举报