1. 谁考了第K名

在一次考试中,每个学生的成绩都不相同,现知道了每个学生的学号和成绩,求考第k名学生的学号和成绩。

【输入格式】

第一行有两个整数,分别是学生的人数n(1<=n<=100),和求第k名学生的k(1<=k<=n)。其后有n行数据,每行包括一个学号(整数)和一个成绩(浮点数),中间用一个空格分隔。

【输出格式】

输出第k名学生的学号和成绩,中间用空格分隔。

【样例输入】

5 3

90788001 67.8

90788002 90.3

90788003 61

90788004 68.4

90788005 73.9

【样例输出】

90788004 68.4

#include <iostream>
#include <algorithm>
using namespace std;
struct student{
    int num;
    double score;    
}; 
bool cmp(student x,student y){
    return x.score > y.score;
}
int main(){
    int n,k;
    cin >> n>>k;
    student stu[101];
    for(int i = 1;i <= n;i++){
        cin >> stu[i].num>>stu[i].score;
    }
    sort(stu+1,stu+n+1,cmp);
    cout << stu[k].num << " " << stu[k].score <<endl;
    return 0;
}

2. 众数

由文件给出N个1到30000间无序数正整数,其中1≤N≤10000,同一个正整数可能会出现多次,出现次数最多的整数称为众数。求出它的众数及它出现的次数。

【输入格式】

输入文件第一行是正整数的个数N,第二行开始为N个正整数。

【输出格式】

输出文件有若干行,每行两个数,第1个是众数,第2个是众数出现的次数。

【样例输入】

12

2  4  2  3  2  5  3  7  2  3  4  3

【样例输出】

2   4

3   4

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
long long a[40000];
int main () {
    long long n,i,j,m,s,t,max;
    cin>>n;
    max=0;
    for (i=1; i<=30000; i++)
        a[i]=0;
    for (i=1; i<=n; i++) {
        cin>>t;
        a[t]=a[t]+1;
    }
    for (i=1; i<=30000; i++)
        if (a[i]>max)
            max=a[i];
    for (i=1; i<=30000; i++)
        if (a[i]==max) cout<<i<<" "<<max<<endl;
}

1、单词排序

输入一行单词序列,相邻单词之间由1个或多个空格间隔,请按照字典序输出这些单词,要求重复的单词只输出一次。(区分大小写)

【输入格式】

    一行单词序列,最少1个单词,最多100个单词,每个单词的长度不超过50,单词之间至少用一个空格间隔。数据不含除字母、空格外的其他字符。

【输出格式】

按字典序输出这些单词,重复的单词只输出一次。

【样例输入】

She wants to go to Peking University to study Chinese

【样例输出】

Chinese

Peking

She

University

go

study

to

wants

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
string s[100001];
int main(){
    int i,n = 0,t,j,k;
    string ss;
    while(cin >> ss){
        n++;
        s[n] = ss;
    }
    for(i = 1;i < n;++i){
        for(j = i+1;j <= n;++j){
            if(s[i] > s[j])
                swap(s[i],s[j]);
        }
    }
    for(i = 1;i <= n;++i){
        if(s[i-1] != s[i])
            cout << s[i] << endl;
    }
    return 0;
} 

2、整数奇偶排序

给定10个整数的序列,要求对其重新排序。排序要求:

1.奇数在前,偶数在后;2.奇数按从大到小排序;3.偶数按从小到大排序。

【输入格式】

输入一行,包含10个整数,彼此以一个空格分开,每个整数的范围是大于等于0,小于等于100。

【输出样例】

按照要求排序后输出一行,包含排序后的10个整数,数与数之间以一个空格分开。

【样例输入】

4 7 3 13 11 12 0 47 34 98

 

【样例输出】

47 13 11 7 3 0 4 12 34 98

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;
long n,i,j,s,a[30000],b[30000];
long se(long l,long r) {
    long v,t,i,j;
    i=l;
    j=r;
    v=a[(l+r)/2];
    do {
        while (a[i]<v) i++;
        while (a[j]>v) j--;
        if (i<=j) {
            t=a[i];
            a[i]=a[j];
            a[j]=t;
            i++;
            j--;
        }
    } while(i<=j);
    if (l<j) se(l,j);
    if (i<r) se(i,r);
}
int main() {
    cin>>n;
    for (i=1; i<=n; i++) cin>>a[i];
    se(1,n);
    cin>>n;
    for (i=1; i<=n; i++) {
        //cin>>s;
        //cout<<a[s]<<endl;
        cin >> b[i];
    }
    for(i = 1;i <= n;i++){
        if(a[b[i]] != 0){
            cout << a[b[i]] << endl;
        }else{
            continue;
        }
    }
}

3、合影效果

小云和朋友们去爬香山,为美丽的景色所陶醉,想合影留念。如果他们站成一排,男生全部在左(从拍照者的角度),并按照从矮到高的顺序从左到右排,女生全部在右,并按照从高到矮的顺序从左到右排,请问他们合影的效果是什么样的(所有人的身高都不同)?

【输入格式】

第一行是人数n(2<=n<=40,且至少有1个男生和1个女生)。

后面紧跟n行,每行输入一个人的性别(男 male 或 女 female)和身高(浮点数,单位:米),两个数据之间以空格分割。

【输出格式】

n个浮点数,模拟站好队后,拍照者眼中从左到右每个人的身高。每个浮点数需保留到小数点后2位,相邻两个数之间用单个空格隔开。

【样例输入】

6

male 1.72

male 1.78

female 1.61

male 1.65

female 1.70

female 1.56

【样例输出】

1.65 1.72 1.78 1.70 1.61 1.56

#include <iostream>
#include <cstdio>
#include <string>

using namespace std;
float a[32768],b[32768];
int main(){
    int n,i,j,k = 0,f = 0;
    string s;
    float t,m;
    cin >> n;
    for(i = 1;i <= n;i++){
        cin >> s >> m;
        if(s == "male"){
            k++;
            b[k] = m;
        }else{
            f++;
            a[f] = m;
        }
    }
    for(i = 1;i <= k;i++){
        for(j = i+1;j <= k;j++){
            if(b[i] > b[j]){
                t = b[i];
                b[i] = b[j];
                b[j] = t;
            }
        }
    } 
    for(i = 1;i <= f;i++){
        for(j = i+1;j <= f;j++){
            if(a[i] < a[j]){
                t = a[i];
                a[i] = a[j];
                a[j] = t;
            }
        }
    }
    for(i = 1;i <= k;i++){
        printf("%0.2f ",b[i]);
    }
    for(i = 1;i <= f;i++){
        printf("%0.2f  ,",a[i]);
    }
    cout << endl;
    return 0;
}